ONS Service not started, during running in vipca from clusterware oracle

ONS Service not started, during running in vipca from clusterware oracle

During installation of Oracle Clusterware in 10g Environment in our Virtual Environment, we are getting the below error during the VIPCA configuration.

During running VIPCA,  ONS service is not started:

2013-02-04 05:42:18.615: [RACG][3067471552] [29944][3067471552][ora.rac2.ons]: Failed to get IP for localhost(2)
Failed to get IP for localhost (2)
Failed to get IP for localhost (2)
onsctl: ons failed to start

On checking on net , we found that we need to configure /etc/hosts file with localhost naming.

Solution:

1. Check the /etc/hosts files for all RAC Node which we are going to configure.

Check the /etc/hosts file:
vi /etc/hosts file

2.  Check the following entry must be present in the /etc/hosts if you don’t have in any one node then copy from other node and past it otherwise make an entry in /etc/hosts files for all RAC node as follows:

127.0.0.1   localhost

3. Hosts file already have this entry as first line. If you removed it or somebody removed it.  To get ride from this problem you need to rewrite it again on all RAC nodes then start the vipca process again for installation. It will works.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s